Admin Panel | Language Stuck Despite Selection

Incident Report for Optimy

Resolved

We would like to inform you that the issue with the language setup in the Admin Panel has been fixed.

Thank you for your patience while we resolved this.
Posted Dec 15, 2025 - 15:37 CET

Investigating

We would like to inform you that the language setup in the Admin Panel is currently experiencing a technical issue.

When accessing Optimy, you might observe that the displayed language is not the one you prefer to use and that you are unable to change it.

Our engineering team is actively working on resolving this issue as quickly as possible.

We sincerely apologize for the inconvenience and appreciate your patience.
Posted Dec 11, 2025 - 10:08 CET
This incident affected: Backend Login (Admin Platform).