Maintenance - Oct. 19th
Incident Report for Optimy
Resolved
The period of potential impact is over.
Posted Oct 19, 2023 - 14:54 CEST
Investigating
Please be advised that your Admin Platform may be down for a few seconds/minutes between 2.30 PM and 4 PM CET today.

We prefer to share this news, even if it may not impact any users.

Apologies for any inconvenience caused.
Posted Oct 19, 2023 - 14:09 CEST
This incident affected: Backend (Admin Platform).