Delays in email deliveries and account verifications

Incident Report for Optimy

Resolved

The incident has been resolved, with no new occurrences reported.

If you are still experiencing issues, kindly reach out to our support team at support@optimy.com so we may assist you.
Posted May 08, 2026 - 09:53 CEST

Monitoring

We have deployed a fix for the delayed emails and can confirm that traffic has been restored.

We will continue to monitor the situation to ensure deliverability.
Posted May 07, 2026 - 16:14 CEST

Investigating

We are currently experiencing delays in the delivery of emails sent from our platform. This may affect account verification, as verification links could arrive late or out of sequence.

Our team is actively investigating and working to restore normal delivery times as quickly as possible. We will post updates here as more information becomes available.
Posted May 07, 2026 - 15:25 CEST
This incident affected: Backend (Admin Platform) and Frontend (Submission Platform).