Admin Panel | User creation slow or not working

Incident Report for Optimy

Monitoring

This should be fixed now.
We are monitoring the situation.
Posted Jun 10, 2026 - 15:29 CEST

Investigating

We are currently experiencing an issue affecting user creation in the admin panel. When creating a new user with a team assigned, the process may take several minutes or appear to fail entirely.

Our technical team is actively investigating and working on a fix. We will provide updates as the situation evolves.
Posted Jun 10, 2026 - 11:14 CEST
This incident affects: Backend (Admin Platform).