Admin Panel - Contacts > Project submitters page might not load

Incident Report for Optimy

Resolved

This incident has been resolved.

Thank you for your patience while we were working on this.
Posted 9 days ago. Mar 24, 2025 - 12:25 CET

Identified

In the Admin Panel, you might notice that the page Contacts > Project Submitters does not load the results.

Our engineering team has identified the issue and they are working on a solution.

Apologies for the inconvenience, and thank you for your patience while we are working on it.
Posted 16 days ago. Mar 17, 2025 - 16:18 CET
This incident affected: Backend (Admin Platform).