Planned Maintenance on EU servers on 2/3 March
Incident Report for Optimy
Resolved
The maintenance has been successfully performed.

Best regards,
Posted Mar 04, 2024 - 13:13 CET
Investigating
On 2nd and 3rd of March, we will perform a maintenance on EU servers to improve stability and performance.

During those two days, the performance of all our platforms - Admin Panel, Submission Platform, Evaluation Platform, Volunteer Platform - might be impacted.
You could experience some slowness and the platforms could also be temporary unavailable.
Posted Feb 19, 2024 - 09:26 CET