Budget Excel export does not work

Incident Report for Optimy

Investigating

Reports > Budget > export to Excel

Issue - It is currently not possible to export Budget Lists into Excel in Reports > Budget.

Please subscribe to this incident should you wish to receive automatic updates.
We will provide updates and keep you informed,
Posted Feb 16, 2026 - 15:41 CET
This incident affects: Backend (Admin Platform).