A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2026 - 12:00 CET
Identified
Exporting project data in Excel results in "Related Project" being mentioned multiple times in the Excel export, if a "Related project" is associated to the project. We have indentified the cause of the issue and are working on a resolution.
Posted Jan 21, 2026 - 17:17 CET
This incident affected: Backend Login (Admin Platform).