RESOLVED - EU - Processing Delays

Incident Report for Optimy

Resolved

The issue has been fixed.

Thank you for your patience, we apologize for any inconvenience caused,

Have a nice day!
Posted Jul 03, 2025 - 10:10 CEST
This incident affected: Backend (Admin Platform) and Frontend (Submission Platform).