Back-office + Submission Platform: Impossible to validate project submitter email change
Incident Report for Optimy
Resolved
The issue has been solved.

Sorry for the inconvenience.
Posted Nov 08, 2023 - 12:03 CET
Identified
A fix has been found and it passed the QA verification.

It will be released later this week.

Thank you for your patience.
Posted Nov 07, 2023 - 10:14 CET
Investigating
When you change the email address linked to a project submitter account (both from the back-office and the Submission Platform), you receive an automatic email with a link to confirm the change.

Due to a technical issue, the link in the email address is currently not working, preventing the email address change.

Our technical team is working on it. We will give you updates as soon as possible.
Posted Oct 31, 2023 - 14:23 CET