Maintenance scheduled on 18 June

Incident Report for Optimy

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 17:03 CEST

Monitoring

To ensure the continued performance and reliability of our solution, we will be conducting maintenance on the Optimy software on Wednesday 18 June.

Users hosted on our US server: 10 am CET / 4 am EDT
Users hosted on our EU and CH servers: 8 pm CET / 2 pm EDT

Please note that users may experience reduced performance during this period. We apologize for any inconvenience this may cause.

We will update you on 19 June to confirm the successful completion of the maintenance.
Posted Jun 17, 2025 - 09:47 CEST
This incident affected: API, Backend Login (Admin Platform), Backend (Admin Platform), Frontend (Submission Platform), Evaluation Platform, and Volunteer Platform.