EU - Processing Delays

Incident Report for Optimy

Resolved

The issue has been fixed.

Thank you for your patience, we apologize for any inconvenience caused,

Have a nice day!
Posted Jul 03, 2025 - 09:00 CEST

Investigating

We are currently experiencing delays in data processing within our EU server, meaning only EU clients are impacted. This may result in delays in receiving emails, seeing new submissions, or receiving exports.

We sincerely apologize for any inconvenience this may cause. Our IT team is actively working on a resolution.

We will provide further updates as soon as more information becomes available.

Thank you for your understanding.
Posted Jul 02, 2025 - 17:40 CEST
This incident affected: Backend (Admin Platform) and Frontend (Submission Platform).